Below are the requirements for access Blackboard Collaborate on your Portable Device. The 2 operating systems supported are Ios and Android.

IOS: Versions 4.3 to 6.1.4
Device: IPad 2, 3 & 3.5, IPod Touch GEN3, GEN4 & GEN5, IPhone 3GS, 4, 4s &5

Android:
V 4.1.1: Samsung Galaxy S3, Galaxy Tablet 10.1
V 4.x: Samsung Galaxy S2
V 4.3: Nexus 7 Tablet
V 4.2: Nexus 10 Tablet
V 2.3.4: LG Optimus Black
V 4.x customized: Kindle Fire 8.9
Other Devices Provisional support with V 2.3

Supported Web Browsers:

Android: Chrome Browser & Browser

Kindle Fire HD: Silk Browser